Remote Support 24.1 Supported Platforms

Android

Android Version Customer Client Presentation Attendee Jump Client Representative Console
Android 7 - 13

Yes

Yes

Yes

Yes

iOS – iPhone, iPad, iPod

iOS Version Customer Client Presentation Attendee Representative Console
14.x

No

No

Yes

15.x

No

No

Yes

16.x

Yes

Yes

Yes

17.x

Yes

Yes

Yes

Linux Desktop

Linux Version Customer Client Jump Client Representative Console
Debian 11 and 12

Yes

Yes

No

Fedora 38 - 39

Yes

Yes

No

RHEL 8.8 and 8.9

Yes

Yes

Yes

RHEL 9.2 and 9.3

Yes

Yes

Yes

Ubuntu 20.04 LTS

Yes

Yes

Yes

Ubuntu 22.04 LTS

Yes

Yes

Yes

Ubuntu 24.04 LTS

Yes

Yes

Yes

To be considered certified by BeyondTrust, the specified Linux distribution and version must be installed in a standard configuration (all included libraries are left in place, environment variables are unchanged, etc.). A non-standard configuration could prevent BeyondTrust from functioning properly.

Other Linux distributions, configurations, and versions not specifically certified by BeyondTrust may work, given the proper dependencies.

RHEL 8.9 and 9.3 no longer ship with an OpenGL dependency needed to run the Access Console. In order to install the console on those versions, you must first install libglvnd-opengl.

Linux Server

Linux Version Headless Jump Client Customer Client Jump Client Representative Console
Debian 11 and 12

Yes

No

No

No

Fedora 38 - 39

Yes

No

No

No

RHEL 8.8 and 8.9

Yes

No

No

No

RHEL 9.2 and 9.3

Yes

No

No

No

Ubuntu 20.04 LTS

Yes

No

No

No

Ubuntu 22.04 LTS

Yes

No

No

No

Amazon Linux 2 (AL2)

Yes

No

No

No

Amazon Linux 2023 (AL2023)

Yes

No

No

No

Raspberry Pi

Raspberry Pi Version Headless Jump Client Customer Client Jump Client Representative Console
Raspberry Pi OS Desktop (10-Buster)

No

No

No

No

Raspberry Pi OS Lite (10-Buster)

No

No

No

No

Raspberry Pi OS Desktop (11-Bullseye)

Yes

No

No

No

Raspberry Pi OS Lite (11-Bullseye)

Yes

No

No

No

Raspberry Pi OS Desktop (12-Bookworm)

Yes

No

No

No

Raspberry Pi OS Lite (12-Bookworm)

Yes

No

No

No

macOS

macOS Version Customer Client & Presentation Attendee Jump Client Representative Console
macOS 10.15 (Catalina)

Yes

Yes

Yes

macOS 11 (Big Sur) x86 or Apple silicon

Yes

Yes

Yes

macOS 12 (Monterey) x86 or Apple silicon

Yes

Yes

Yes

macOS 13 (Ventura) x86 or Apple silicon

Yes

Yes

Yes

macOS 14 (Sonoma) x86 or Apple silicon

Yes

Yes

Yes

All macOS clients are 64-bit as of Remote Support 18.1.

Windows Desktop

Windows Version Customer Client & Presentation Attendee Jump Client Representative Console
Windows 7 SP1

Yes

Yes

No

Windows 10 (21H1 and lesser)

No

No

No

Windows 10 (21H2 and 22H2)

Yes

Yes

Yes

Windows 11

(21H2 lesser)

No

No

No

Windows 11

(22H2 and 23H2)

Yes

Yes

Yes

Windows Server

Windows Version Customer Client & Presentation Attendee Jump Client Representative Console
Windows Server Core

No

No

No

Windows Server 2016

Yes

Yes

No

Windows Server 2019

Yes

Yes

No

Windows Server 2022

Yes

Yes

No

The above listed versions assume both 32 and 64-bit versions where applicable and reasonable.

Virtual Desktop Environments

Platform Customer Client Jump Client Representative Console
Citrix XenDesktop 7

Yes

Yes

Yes

VMWare Horizon 8

Yes

Yes

Yes

Citrix XenApp 6.5

Yes

Yes

Yes

Virtual desktop environment support assumes that Remote Support clients work in a supported OS environment, virtual or otherwise.

Browsers (OS)

Browser OS Version /login /console /appliance Public Portal C2C C2c - Screen Shared
Edge (Chromium)

Yes

Yes

Yes

Yes

Yes

Yes

Firefox

Yes

Yes

Yes

Yes

Yes

No

Safari 16.x and 17.x (Mac)

Yes

Yes

Yes

Yes

Yes

No

Safari (iOS)

No

No

No

Yes

Yes

No

Google Chrome

Yes

Yes

Yes

Yes

Yes

Yes

Chrome (iOS)

No

No

No

Yes

Yes

No

Chrome (Android)

No

No

No

Yes

Yes

No

Chrome (OS)

Yes

Yes

Yes

Yes

Yes

Yes

Jumpoint

Operating System JP Host JP Target
Windows Server 2016

Yes

Yes

Windows Server 2019

Yes

Yes

Windows Server 2022

Yes

Yes

Windows 10

Yes

Yes

Ubuntu 20.04

Yes

Yes

Ubuntu 22.04

Yes

Yes

RHEL 8

Yes

Yes

Red Hat 9

Yes

Yes

Amazon Linux 2 (AL2)

Yes

Yes

Amazon Linux 2023 (AL2023)

Yes

Yes

Debian 11

Yes

Yes

Debian 12

Yes

Yes

Remote Support supports only Microsoft's RDP server implementation built into Windows operating systems and Remote Desktop Session (formerly Terminal Services) Hosts.

Connection Agent

Operating System
Windows Server 2016

Yes

Windows Server 2019

Yes

Windows Server 2022

Yes

Windows 10

Yes

Supported Platforms for Other Features

Some product features may have additional platform requirements, restrictions, or conditions. Refer to the documentation for that product feature for more information.