Privileged Remote Access 20.1.5 Release Notes

February 4, 2021

Requirements:

  • This version of Privileged Remote Access has been certified for physical BeyondTrust Appliances, virtual BeyondTrust Appliances, and cloud deployment models.
  • 20.1.5 PA requires Base 5.5.0, 6.0.1, or Base 5.6.0 (b300 series Physical Appliances, Virtual Appliances, and FIPS mode Appliances).

Issues Resolved :

  • Resolved issues with smart card authentication.
  • Resolved a failure to send alert emails.
  • Resolved a screen sharing issue when client runs as system service.
  • Resolved issue with Atlas node selection by network prefix.
  • Resolved timing issue with pinned client configuration reload.
  • Resolved missing line in Special Actions menu.
  • Resolved missing mouse click events in session forensics reports.

Notes: