Privileged Remote Access 20.1.4 Release Notes

August 12, 2020

Requirements:

  • This version of Privileged Remote Access has been certified for physical BeyondTrust Appliances, virtual BeyondTrust Appliances, and cloud deployment models.
  • 20.1.4 PA requires Base 5.5.0 or Base 6.0.1.

Issues Resolved :

  • Resolved file lock issue when copy/pasting to an RDP endpoint.
  • Resolved issues encountered when testing LDAP providers with MFA enabled.
  • Resolved issue with ECM credential store display encountered when performing remote Jumps.
  • Resolved issue in which correct hostname was not used when issuing external invite to alternate site.
  • Corrected issue in which line breaks in pre-login agreement were not preserved.
  • Resolved issue with node selection in clustered environments.
  • Added new, potentially faster option for LDAP searches.
  • Resolved permission issue with email modification.
  • Resolved issue with Passive Jump Client connection frequency.
  • Resolved issue with remote shell recording conversion.

Notes: