Defendpoint Windows Client 5.3.230.0 SR3 Release Notes

March 8, 2019

For this release, Microsoft Office 2016 should be at version 16.0.6001.1038 or later.

Issues Resolved:

Fixed an ePO Server specific issue that prevented the following Windows Client upgrade paths:

  • 5.3.216.0 GA - 5.3.219.0 SR1
  • 5.3.216.0 GA - 5.3.229.0 SR2
  • 5.3.219.0 SR1 - 5.3.229.0 SR2

This issue is only present when these upgrade paths are attempted using the Defendpoint ePO Extension. Defendpoint ePO Extension customers who have successfully deployed 5.3.216.0 GA, 5.3.219.0 SR1 or 5.3.229.0 SR2 do not need to upgrade to this release; these builds are still fully supported. This issue is not present if you are upgrading from any version of Windows Client 5.2 to any version of Windows Client 5.3 using the Defendpoint ePO Extension.

Prerequisites

Defendpoint Client:

  • .NET Framework 4.0 (Required to use Power Rules, PowerShell audit scripts and PowerShell API)
  • PowerShell 3.0 (Required to use Power Rules, PowerShell audit scripts and PowerShell API)
  • Microsoft SQL Server Compact 4.0 (x86 & x64)
    • Required on the endpoint for Activity Viewer functionality. This prerequisite is included with the executable (EXE) of
  • the Defendpoint Client. If you are using the Defendpoint Client Microsoft Installer (MSI) or the ePO Defendpoint
  • Windows Client zip package you need to manually install this prerequisite.
  • The McAfee Agent must be installed if you are installing the Defendpoint client with switch EPOMODE=1

Defendpoint Activity Viewer:

  • Microsoft SQL Server Compact 4.0
    • Required on the endpoint that will run the Activity Viewer Console. This prerequisite is included with the executable (EXE) of the utility.
  • Microsoft .NET Framework 4.0 Client

The executable version of the client package includes all necessary prerequisites (excluding .NET Framework 4.0), and automatically installs them as necessary.

The Defendpoint Client executable installer automatically installs Microsoft SQL Server Compact. If you do not wish to use the Activity Viewer, and do not wish for this prerequisite to be installed, we recommend you install the Defendpoint Client MSI installation.

Compatibility

Defendpoint Group Policy Console

This release is compatible with the Defendpoint Console 4.5 or later.

Defendpoint ePO Extension

The following Defendpoint Extension versions are compatible with this version of the Defendpoint Client.

Please use the latest Defendpoint ePO Extension at the time of release. If you use an older version of the Defendpoint ePO extension, some Windows client functionality may not be supported. Clients that are newer than the ePO extension may be tolerated depending on the internal product ID.

  • Recommended: 5.3 (all versions)
  • 5.2 (all versions)
  • 5.1 (all versions)
  • 5.0 (all versions)

iC3 Windows Adapters

The following iC3 adapters are compatible with this version of the Defendpoint Windows client.

  • 1.4 (all versions)
  • 2.1 (all versions)

McAfee Agent

The following McAfee supported versions of these Agents are compatible with this version of the Defendpoint Client:

  • Recommended: 5.6.x
  • 5.5.x
  • 5.0.x

Version 4.8 and older of the McAfee agent are not supported with this release.

McAfee ePO Server

The following McAfee supported ePO Server versions are compatible with this version of the Defendpoint Client:

  • Recommended: 5.10 (all versions)
  • 5.9 (all versions)
  • 5.3 (all versions)

Version 5.2.21.0 GA of the Defendpoint Windows Client is certified with ePO Server 5.9.

Version 5.2.28.0 SR1 of the Defendpoint Windows Client is certified with ePO Server 5.10.

McAfee Endpoint Security (ENS)

The following McAfee supported Endpoint Security versions are compatible with this version of the Defendpoint Client:

  • Endpoint Security (ENS) Adaptive Threat Protection (ATP) 10.x
    • With Generic Privilege Escalation Prevention (GPEP) enabled and disabled
  • ENS Firewall 10.x
  • ENS Threat Prevention 10.x
  • ENS Web Control 10.x

McAfee MOVE Multi-Platform Client

The following McAfee supported versions of the MOVE Multi-Platform Client are compatible with this version of the Defendpoint Client:

  • MOVE AV[Multi-Platform] SVA Manager 3.6.1.141
  • MOVE AV[Multi-Platform] Client 3.6.1.141
  • MOVE AV[Multi-Platform] License Extension 3.6.1.141
  • MOVE AV[Multi-Platform] Offload Scan Server 3.6.1.141

We do not support the agentless version of McAfee MOVE.

If the version of McAfee MOVE is compatible with the McAfee Agent you're using then Defendpoint is also compatible.

Supported Operating Systems

Privilege Management/Application Control Support

These platforms are supported with the latest service pack or update applied:

  • Windows 7
  • Windows 8 and 8.1
  • Windows 10 builds Enterprise 2015 LTSB, Enterprise 2016 LTSB, 1607, 1703, 1709, 1803 and 1809
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019

Content Isolation

Content Isolation is supported with Windows 10 1709 and lower.

These platforms are supported with the latest service pack or update applied:

  • Windows 7
  • Windows 8 and 8.1
  • Windows 10 builds 1507, 1607, 1703, 1709
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016

Primary Application Support

  • Internet Explorer 8+
  • Google Chrome
  • Microsoft Office Word 2007/2010/2013/2016
  • Microsoft Office Excel 2007/2010/2013/2016
  • Microsoft Office PowerPoint 2007/2010/2013/2016
  • Microsoft Office Outlook 2007/2010/2013/2016
  • Adobe Reader 10+
  • Zip Archivers (Winzip, WinRAR, Windows Compressed Folders)

If you are upgrading Defendpoint you may need to update your workstyles to incorporate newly supported features/applications.