BeyondTrust Updater 2.9 Release Notes

February 4, 2020

New Features and Enhancements:

  • Added operating system dependencies to restrict download of incompatible package versions onto client machines.

Notes:

  • Requires .NET 4.52
  • Available through BeyondTrust Updater