New Features: PowerBroker for Mac 1.3

New Feature Highlights for PowerBroker for Mac 1.3

Version 1.3 expands on its market-leading capabilities. Please see the next page for a summary of new features.

Sierra Support

With version 1.3, PowerBroker for Mac now offers support for OS Sierra. This provides parity functionality with previously supported versions of the OS, and enables organizations to confidently and securely adopt the latest OS version without the risk of excessive user privileges.

Passive Rule Support

PowerBroker for Mac version 1.3 now offers a Passive rule action. Passive rules are used to ensure an application can be executed, even from within an otherwise ‘denied’ folder. This new capability enhances the included Application Control (Deny Rule) capabilities of the product.

Note: This feature requires the PowerBroker Editor v7.2.1 or higher.

‘Run Elevated’ Menu Option

The Run Elevated menu option is now enabled by default for all users. With version 1.3, administrators will no longer need to manually enable the option under Keyboard-Shortcuts-Services to allow users access to the Shell Rule.

Elevating Installers (.app)

As part of some application installers, the user is asked to drag and drop the application into the ./Applications folder. In previous versions of PowerBroker for Mac this action was not allowed as part of the elevation. However, version 1.3 now allows for this action, making elevated installs more seamless for your end-users.

Customer Enhancements and Other Items

  • The PBMac silent installer now retains settings on upgrade.
  • A rule may now be created to elevate simulator downloads in XCode. It is still recommended that an authorized XCode user be a member of the ‘_developer’ group.
  • An issue was resolved when adding additional users to unlock an encrypted PC via FileVault.
  • Deny rules now match correctly on applications launched from the ./Applications folder.
  • An enhancement was made when elevating adding printers to a system.
  • UI applications no longer require pbm_elevate when using the, ‘Run As Root’ action.
  • Mac OS X 10.9 (Mavericks) is no longer supported.

Read the complete Documentation!

document
Download Now