Privilege Management for Windows 22.5.2 Release Notes

August 18, 2022

Requirements:

  • Microsoft .NET Framework 4.0 (required to use Activity Viewer, Power Rules, PowerShell audit scripts, and PowerShell API)
  • Microsoft .NET Framework 4.6.2 (required to use Agent Protection)
  • Microsoft .NET Framework 4.8 (required to use Multifactor Authentication with an OIDC provider)
  • PowerShell 3.0 (required to use Power Rules, PowerShell audit scripts, and PowerShell API)
  • Microsoft SQL Server Compact 4.0 (required on the endpoint that will run the Activity Viewer console)
  • McAfee Agent (required if you are installing the Privilege Management client with switch EPOMODE=1)
The executable version of the client package includes all necessary prerequisites (excluding .NET Framework) and automatically installs them as necessary. If you use the MSI or ZIP package, you must manually install any necessary prerequisites.

Issues Resolved:

  • Resolved a potential crash in the EPM service in version 22.5. If you are using this version, we recommend upgrading.

Compatibility:

  • Privilege Management Policy Editor 22.5 (recommended), 5.6+
  • Privilege Management ePO Extension 21.2 (recommended), 5.2+
  • Privilege Management Console Windows Adapter 22.5 (recommended), 21.1
  • BeyondInsight/Password Safe 22.1 (recommended), 7.2
  • McAfee Agent 5.7 (recommended)
  • McAfee ePO Server 5.10 (recommended), 5.9

Supported Operating Systems:

  • Windows 11
    • 21H2
  • Windows 10
    • 21H2
    • 21H1
    • 20H2
    • 1909
    • LTSB 2015
    • LTSB 2016
    • LTSC 2019
  • Windows 8.1
  • Server
    • 2022
    • 2019
    • 2016
    • 2012R2
    • 2012

For more information about compatibility, please see Privilege Management for Windows and Mac: Supported Versions and Operating System Compatibility.

Notes:

  • Privilege Management for Windows 22.5.2 supports upgrades from Privilege Management for Windows 5.2+.