iC3 2.1 SR2

December 17, 2018

Enhancements:

  • The default minimum adapter poll time for pending commands is now 60 minutes. An additional delay is also applied based on the CPU load of the node that the adapter is connected to. The minimum adapter poll time that we support is 5 minutes
  • The Tenant CA is now loaded on the iC3 Fabric Application at start-up to support asynchronous requests. If this process fails, ServiceFabric Explorer reports the error.
  • Errors in ServiceFabric Explorer are now removed after 30 minutes providing the underlying issue has been resolved.

Bugs Fixed:

  • Updated the EventGateway to ensure events traffic is distributed evenly across the cluster.

Prerequisites

Defendpoint Clients

The prerequisites for the Defendpoint clients can be found in the Client Release Notes.

iC3 Windows Adapter

You need to deploy iC3 prior to installing your Windows adapter so you can access the Installation Key and Installation ID which are parameters for the adapter installation.

iC3 Mac Adapter

You need to deploy iC3 prior to installing your Mac adapter so you can access the Installation Key and Installation ID which are parameters for the adapter installation.

Compatibility

Defendpoint Client

Windows

  • 5.3.x (all versions)
  • 5.2.x (all versions)
  • 5.1.x (all versions)

Trusted Application Protection (TAP) events are not supported in Defendpoint 5.1.95 GA.

Mac

  • 5.2.x (all versions)
  • 5.0.19950.0 SR1

Defendpoint Management Console

  • 5.3.x (all versions)
  • 5.2.x (all versions)
  • 5.1.149.0 SR1

Earlier versions of the Defendpoint Management Console are not supported for use with this iC3 release.

iC3 Adapters

Windows Adapter

  • 2.1.26339.0 SR1

Mac Adapter

  • 2.0.28710.0 SR2
  • 2.0.21649.0 GA

Reporting Database

  • Defendpoint Privilege Management Reporting 5.1.x (all versions)

Supported Operating Systems and Browsers

Please see the relevant Installation Guide for your chosen method of deploying iC3 for the different machines and operating systems that are required.

Deployment Machine

  • Windows 10
  • Windows Server 2016 Standard or Enterprise

For the Windows iC3 Adapter:

  • Microsoft Windows 7 and higher
  • Windows 2012 R2
  • Windows 2016

For the OS X iC3 Adapter:

  • OS X 10.11 El Capitan
  • macOS 10.12 Sierra
  • macOS 10.13.2 High Sierra

For the iC3 portal:

  • Microsoft Internet Explorer
  • Google Chrome
  • Apple Safari
  • Mozilla Firefox