pbpatchinstall

  • [ver 5.1.2 and earlier]: pbpatchinstall not available.
  • [ver 5.2 and later]: pbpatchinstall available.

pbpatchinstall enables you to install and uninstall patches for installations that are running Privilege Management for Unix and Linux v4 and later.

All Privilege Management for Unix and Linux daemons running a process during the patch installation should be stopped before using pbpatchinstall and restarted after using pbpatchinstall.

Only root can run pbpatchinstall. It must be run from the install directory where the Privilege Management for Unix and Linux patch was untarred. For example, if you untarred the Privilege Management for Unix and Linux patch from the /opt/beyondtrust directory, the patch install directory is then /opt/beyondtrust/powerbroker/v6.0/ pbx86_linuxA-6.0.0-16-sp1/install.

pbpatchinstall should not be moved from this install directory because it is dependent on the included Privilege Management for Unix and Linux installer scripts (sy_install_support and pb_install_support) that are located there.

pbpatchinstall allows a Privilege Management for Unix and Linux patch to load if the patch release number differs from the Privilege Management for Unix and Linux installation release number. However, it does not allow a patch to load if the patch version does not match the Privilege Management for Unix and Linux installation major and minor version numbers.

pbpatchinstall does not run on Privilege Management for Unix and Linux versions earlier than v4.0 due to binary - version argument limitations. Also, pbpatchinstall does not report the binary version for executable files pbnvi or pbuvqrpg.

To uninstall a patch, go to the install directory where the patch was originally installed and execute pbpatchinstall -u. pbpatchinstall attempts to uninstall the patch version that is defined by the install directory where pbpatchinstall resides.

For example, if you run pbpatchinstall from the /opt/beyondtrust/powerbroker/v5.1/ pbx86_linuxA-5.1.2-03-sp1/install directory, pbpatchinstall attempts to uninstall the Privilege Management for Unix and Linux pbx86_linuxA-5.1.2- 03-sp1 patch from that install directory.

If multiple patches are installed and you need to remove one or more of them, they must be removed in the reverse order from the order in which they were added.

Syntax

pbpatchinstall [options]
pbpatchinstall -p test

This creates a Privilege Management for Unix and Linux installation using the prefix test.

Arguments

-a

This option and its required argument explicitly specify which Unix or Linux architecture file to install.

If the –a option is used, then the installer compares the expected flavor and the flavor that is specified with the -a option and displays a warning if they do not match.

In Privilege Management for Unix and Linux v3.2 and earlier, the installation does not cross- check flavors. Beginning with Privilege Management for Unix and Linux v3.5, the installation script cross-checks flavors.

-f Forces the installation of the patch without a prompt, regardless of the release number.
-h Displays the usage message and exits.
-p prefix

Sets the Privilege Management for Unix and Linux installation prefix.

-s suffix Sets the Privilege Management for Unix and Linux installation suffix.
-u

Uninstalls the Privilege Management for Unix and Linux patch installation.

-v

Displays the version of pbpatchinstall and exits.

For more information, please see the following: