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Integrate BeyondTrust Privilege Management for Windows
with BeyondInsight

Overview

Privilege Management combines privilege management and application control technology in a single lightweight agent. This
scalable solution allows global organizations to eliminate admin rights across the entire business. With the integration between
BeyondInsight and Privilege Management, you have a proven privilege management solution that transmits data about your
endpoints and policies to a centralized management console with the reporting and analytics capabilities needed to effectively
operate your business in a secure fashion.

Network Considerations

TCP Port 443
An event service is used to communicate between PM and BeyondInsight using port 443. Events from PM
are sent to BeyondInsight using this service. Communications over this channel is secured by means of a
client certificate.

This guide details how to use the BeyondInsight default client certificate (eEyeEmsClient), but you can use your own Private Key
Infrastructure (PKI) if you wish.

For more information, please refer to the Use a Domain PKI for BeyondInsight Communication section of the BI Installation
Guide at www.beyondtrust.com/docs/beyondinsight-password-safe/bi/.

Prerequisites

l BeyondInsight version 6.9.0.712 or later
l Privilege Management for Windows 5.4.228.0 or later

Note: The reporting component is available in BeyondInsight versions 6.10 and later.

For information on integrating BeyondTrust Privilege Management for Mac with BeyondInsight, please see the Privilege
Management for Mac BeyondInsight Integration Guide, at www.beyondtrust.com/docs/privilege-management/mac.htm.
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Steps to Integrate Privilege Management for Windows with
BeyondInsight
Once you have BeyondInsight and Endpoint Privilege Management installed in your environment, you will need to configure both
instances to communicate with each other. Below is a list of high level steps needed to complete the integration.

l Create and deploy the BeyondInsight client certificate to all potential Privilege Management for Windows endpoints or policy
editor machines.

l Using your method of choice, deploy the Privilege Management for Windows client and BeyondInsight adapter on all
endpoints, using the BIMODE=1 install flag.

l Verify BeyondInsight is receiving heartbeats and information from Privilege Management for Windows endpoints.
l Configure the policy editor to communicate with BeyondInsight and test the connection.
l Create a new policy in the editor.
l Create a Smart Rule in BeyondInsight.
l Assign and deploy a policy from BeyondInsight.
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Installation Information for BeyondInsight and Privilege
Management for Windows

Create and Deploy the BeyondInsight Client Certificate for Privilege Management for Windows

To establish communication between BeyondInsight and Privilege Management for Windows clients, a client certificate must be
generated from BeyondInsight, and installed on every client needing to transmit information to BeyondInsight. We recommend
installing the BeyondInsight client certificate prior to the Privilege Management for Windows client.

Tip: You do not need to generate a client certificate if there is already a certificate for PowerBroker for Windows Endpoint
Protection Platform or BeyondInsight Network Security Scanner. You can use the existing client certificate for your
Privilege Management for Windows assets.

Generate Client Certificate MSI

1. On the BeyondInsight Server, go to C:\Program Files (x86)\eEye
Digital Security\Retina CS.

2. Run REMEMConfig.exe, which opens the BeyondInsight
Configuration Tool.

3. Click on the Generate Certificate.msi link. A command prompt
opens, indicating the MSI is being generated.
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4. Once the prompt closes, the MSI appears in the C:\Program Files
(x86)\eEye Digital Security\Retina CS\Utilities\msi directory.

Deploy the Certificate MSI for Privilege Management for Windows
After you have generated the certinstaller.msi from BeyondInsight, you must deploy and install the MSI on each machine you wish to
communicate with BeyondInsight, using Administrator rights. You may deploy the MSI using the following methods:

Command prompt already running as Administrator

1. Add a copy of the certinstaller.msi to the machine
2. Run cmd.exe as administrator
3. Run the following command:msiexec /i certinstaller.msi

Group Policy

Use the Group Policy Management Console (GPMC) to deploy certificate packages to your client computers.

1. To deploy the certificate MSI package, copy the certificate MSI package to an accessible location.
2. Click Start > Control Panel > Administrative Tools > Group Policy Management to open the GPMC. If the GPMC is not

already installed, it can be downloaded from www.microsoft.com/en-us/download.
3. In the GPMC, click Forest > Domains > Mydomain > Group Policy Objects.
4. To create a new GPO, right-click Group Policy Objects, and click New.
5. Enter a name for the GPO and click OK. Alternatively, you can add configurations to an existing GPO.
6. Right-click the GPO and click Edit to launch the Group Policy Management Editor to configure settings for the GPO.
7. In the Group Policy Management Editor, click Computer Configuration > Policies > Software Settings.
8. Right-click Software Installation and click New > Package.
9. Select the certificate MSI installer package, and click Open.
10. Select Assigned and click OK. After a brief delay, the name of the software to be installed is displayed in the Details pane of

the Group Policy Management Editor.

l If the name does not appear, right-click Software Installation and click Refresh until it does.
l To modify installation settings, double-click the item name in the display pane.
l To remove an item, right-click the item name and select All Tasks > Remove.

Restart each client computer to initiate the installation. T'his can be done manually or by using Group Policy mechanisms.
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An enterprise software management tool of your choice, for example, SCCM.

Be sure to consult the guides for the management tool you use.

After you have deployed the client certificate, confirm it is on the system, following the steps below.

1. Run the Microsoft Management Console (MMC) as administrator.
2. Go to File > Add/Remove Snap-in.

3. From the Snap-inmenu, select Certificates, and click Add >.
4. In the Certificates snap-in dialog, select Computer account.

5. Choose Local computer: (The computer this console is
running on). Click Finish.
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6. In the MMC Console, expand Console Root > Certificates
(Local Computer).

7. Expand both the Personal > Certificates directory and the
Trusted Root Certification Authorities directory to ensure the
eEyeEmsClient client certificate is listed.

Note: If the certificates are not present, it is possible they were
incorrectly installed in the Certificates (Current User) store. If
you find them there, delete them and uninstall certinstaller.msi
from Programs & Features (appwiz.cpl) before repeating
these steps.

Privilege Management for Windows Installation
For BeyondInsight integration with Privilege Management for Windows, you must set the BIMODE installer variable to 1. In the
majority of cases, only the URL of your BeyondInsight Event Service must be specified. For context, example installation strings are
provided below:

PrivilegeManagementForWindows_x64.exe /v"BIMODE=1
BEYONDINSIGHTURL=https://example.com/EventService/Service.svc"

msiexec.exe /i PrivilegeManagementForWindows_x64.msi BIMODE=1
BEYONDINSIGHTURL="https://example.com/EventService/Service.svc"

If you are using a custom certificate or workgroup, you can specify non-default values as additional install variables, as shown in the
following examples.

PrivilegeManagementForWindows_x64.exe /v"BIMODE=1
BEYONDINSIGHTURL=https://example.com/EventService/Service.svc BEYONDINSIGHTCERTNAME=CertExample
BEYONDINSIGHTWORKGROUP=BeyondTrustWorkGroup"

msiexec.exe /i PrivilegeManagementForWindows_x64.msi BIMODE=1
BEYONDINSIGHTURL="https://example.com/EventService/Service.svc" BEYONDINSIGHTCERTNAME="CertExample"
BEYONDINSIGHTWORKGROUP="BeyondTrustWorkGroup"

The following table details the available installer variables and their default values:
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Location Name Default Installer Variable Name

HKEY_LOCAL_
MACHINE\SOFTWARE\Avecto\Privileg
e Guard Client

BeyondInsightUrl
[Empty] - You
must specify
this

BEYONDINSIGHTURL

BeyondInsightCertName eEyeEmsClien
t BEYONDINSIGHTCERTNAME

BeyondInsightWorkgroup BeyondTrust
Workgroup

BEYONDINSIGHTWORKGROU
P

BeyondInsightHeartbeatIntervalMin
s 720

BeyondInsightPolicyIntervalMins 90

Tip: The default values of BeyondInsightPolicyIntervalMins and BeyondInsightHeartbeatIntervalMins can be
shortened for testing purposes (low numbers of machines). Be aware that decreasing these values increases load on the
BeyondInsight Event Service server.

IMPORTANT!

When updating the clients on an existing deployment of BeyondInsight and Privilege Management for Windows, the registry keys
from the previous install will be removed. Any previously-specified variables in the install string must be restated in an upgrade.

Ensure that endpoints are registered in BeyondInsight

After deploying your Privilege Management for Windows endpoints, you should ensure that BeyondInsight is receiving heartbeats
and information from them. Once they check in, the endpoints are shown as entries on the Assets grid in BeyondInsightas well as the
Endpoint Privilege Management Agents grids.
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Prepare the Privilege Management Policy Editor System

Create and Deploy the BeyondInsight Client Certificate for Privilege Management Policy Editor

In BeyondInsight version 6.10, you can run the certinstaller.msi to deploy the certificate to your Policy Editor machines. Generating
and deploying the certinstaller.msi is described earlier in this guide.

For more information, please see "Installation Information for BeyondInsight and Privilege Management for Windows" on
page 5.

In BeyondInsight version 6.9, go through the following procedure. Export the eEyeEmsClient certificate from your BeyondInsight
server and import the eEyeEmsClient.pfx file to the Local Computer Personal certificate store on all Policy Editor machines.

1. Export the eEyeEmsClient certificates from your BeyondInsight
instance using the BeyondInsight Configuration application and
click Generate Certificate Zip.

2. Choose an export directory and a password.

3. Log on to the Policy Editor machine as the user who is responsible for editing policy.
4. Open Manage Computer Certificates (certlm.msc).
5. Import the eEyeEmsClient.pfx file to the Certificates > Local Computer (Personal) certificate store. You need to provide the

password from the previous step.
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6. Right-click Personal store and go to All Tasks > Import in the
context menu to start the Certificate Import Wizard.

7. Click Next.

8. Click Browse.
9. Change the File Type to *.pfx and browse to the

eEyeEmsClient.pfx file (previously exported from
BeyondInsight).
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10. Enter the password you chose when exporting from
BeyondInsight. Leave other settings as default.

11. Import to the Personal store (default), click Next and then Finish.

12. Copy eEyeEmsCA from Personal\Certificates to Trusted Root Certification Authorities\Certificates.

SALES: www.beyondtrust.com/contact SUPPORT: www.beyondtrust.com/support DOCUMENTATION: www.beyondtrust.com/docs 12
©2003-2020 BeyondTrust Corporation. All Rights Reserved. Other trademarks identified on this page are owned by their respective owners. BeyondTrust is not a chartered bank or trust company, or depository
institution. It is not authorized to accept deposits or trust accounts and is not licensed or regulated by any state or federal banking authority.

TC: 9/24/2020

PRIVILEGE MANAGEMENT FOR WINDOWS

BEYONDINSIGHT INTEGRATION GUIDE



Configure the Privilege Management Policy Editor

After you deploy the client certificate to your Privilege Management Policy Editor machines, you can set up the Privilege Management
Policy Editor and configure the editor to work with BeyondInsight.

1. Launch the Microsoft Management Console (mmc.exe) as an admin and go to File >
Add/Remove Snap-in.

2. In the Available snap-ins menu, locate and select the Privilege
Management Settings (BeyondInsight) snap-in.

3. Click Add >, then click OK. The Privilege Management Settings
(BeyondInsight) snap-in will appear in the Console Root menu.

Test the Connection

Before continuing on with the remainder of the integration setup, you need to test the following:

l Test to ensure that a client certificate of the correct name is available in the certificate store.
l Test to ensure the policy editor can reach the BeyondInsight Server.

To test, click on Remote Server Details from theWelcome page. From
the BeyondInsight Server Details dialog, enter the server details. Then
click Test by Certificate Name and BeyondInsight Server to check
each component.

Note: The Certificate Name andWorkgroup Name fields are
populated with default values.
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If a certificate of the correct name is found, a message appears stating
Valid certificate found in certificate store.

If the BeyondInsight Server can be reached, a message appears stating
The server was reached successfully.

When finished testing, click Save.
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Create a New Policy in the Privilege Management Policy Editor
Once you have established communication between the Privilege Management Policy Editor and the BeyondInsight Server, you can
create a new policy from the editor.

1. From theWelcome page, click New Policy.

2. Enter the credentials used to log into your BeyondInsight
instance.

3. Type in a name for your new policy, and then click OK.

TheWelcome page will update to show more options, including:

l Export Policy
l Import Policy
l Import Template
l Digitally Sign
l Save Report
l Challenge/Response
l BeyondInsight Policy
l BeyondInsight Account
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For more information on policy creation and best practices, please see the Privilege Management for Windows
Administration Guide at https://www.beyondtrust.com/docs/privilege-management/windows/index.htm.

Upload Changes

Once you have created and modified your policy, you can upload your
changes to BeyondInsight by clicking Upload Changes on theWelcome
page.

After you have uploaded your policy to the BeyondInsight Server, you can view it in BeyondInsight Server from Menu > Configuration
> Privilege Management Policies.
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Create a Smart Rule and Assign Policy in BeyondInsight
After you have added and uploaded your policy to BeyondInsight from the policy editor, log into your BeyondInsight instance to create
Smart Rules and assign policies for assets and users.

Tip: If BeyondInsight and Privilege Management for Windows are successfully communicating, the Endpoint Privilege
Management option becomes available under Menu > Assets.

Create a Smart Rule for Assets

1. In your BeyondInsight instance, click on Assets.

2. Click Manage Smart Rules.
3. Click New.
4. From the Smart Rules Manager for Assets dialog, type a name

for your Smart Rule.
5. Check Active.
6. From the Category dropdown, select Assets and Devices.
7. Enter a description, if needed.
8. In the Asset Selection Criteria section, design a query to pull in

the assets you wish to assign policy to.

Tip: For this example, we can narrow down the results of our query to locate our test system, NN-1K12RBR. Choose
Match ALL Criteria. Select Asset fields > Asset Name > contains > NN-1K12RBR.

9. From the Perform Actions dropdown, select Deploy Endpoint Privilege Management Policy.
10. Click the .. button.
11. Select an option from the policy you uploaded from Privilege Management for Windows .
12. Click Save.

For more information about creating and organizing Smart Rules, please see Use Smart Rules to Organize Assets in the
BeyondInsight User Guide at https://www.beyondtrust.com/docs/beyondinsight-password-safe/bi/index.htm.
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Create a Smart Rule for Users

1. In your BeyondInsight instance, click on Policies.

2. Click Manage Smart Rules.
3. Click New.
4. From the Smart Rules Manager for Assets dialog, type a name

for your Smart Rule.
5. Check Active.
6. From the Category dropdown, select Policy Users.
7. Enter a description, if needed.
8. In the Selection Criteria section, design a query to pull in the

users you wish to assign policy to.
9. Click the .. button to build your query.
10. When finished, click Save.
11. From the dropdown, choose the query.
12. Check Discover Users.
13. From the Perform Actions section, choose your policy users and policies you wish to apply. Order policies as needed.
14. Select Show as Group.
15. Click OK.
16. Click Save.

For more information about managing policies for EPM, please see Manage User Policies in the BeyondInsight User
Guide at https://www.beyondtrust.com/docs/beyondinsight-password-safe/bi/index.htm.

Grant Users Permissions to Log into the Policy Editor

If you would like to grant additional users access to log into the Policy Editor, read and write access needs to be included on the
Privilege Management for Windows assets. This access is included by including permissions in the Smart Rule.

1. On the BeyondInsight Home page, click Configuration.
2. On the Configuration grid, select Role Based Access > User Management.
3. Locate the group you wish to edit and click the vertical ellipsis button to the far right.
4. Select View Group Details.
5. In the Group Details pane, click Smart Groups.
6. In the Smart Groups Permissions pane, select the appropriate Smart Group.

SALES: www.beyondtrust.com/contact SUPPORT: www.beyondtrust.com/support DOCUMENTATION: www.beyondtrust.com/docs 18
©2003-2020 BeyondTrust Corporation. All Rights Reserved. Other trademarks identified on this page are owned by their respective owners. BeyondTrust is not a chartered bank or trust company, or depository
institution. It is not authorized to accept deposits or trust accounts and is not licensed or regulated by any state or federal banking authority.

TC: 9/24/2020

PRIVILEGE MANAGEMENT FOR WINDOWS

BEYONDINSIGHT INTEGRATION GUIDE

https://www.beyondtrust.com/docs/beyondinsight-password-safe/bi/index.htm
https://www.beyondtrust.com/docs/beyondinsight-password-safe/bi/index.htm
https://www.beyondtrust.com/docs/beyondinsight-password-safe/bi/index.htm


7. Click either the vertical ellipsis button to the far right or the Assign Permissions button at the top of the list.
8. Click Assign Permissions Full Control.
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Install and Configure Privilege Management Reporting
For assistance installing and configuring Privilege Management Reporting with BeyondInsight, please contact your BeyondTrust
representative.
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