January 2017 Patch Tuesday Blog Post

BeyondTrust Research Team, January 10th, 2017

Patch Tuesday

A new year of course brings with it a new Patch Tuesday. This month, Microsoft has released only four bulletins consisting of one critical and three important-rated advisories. In total, 15 unique vulnerabilities were addressed, the majority of which are related to Adobe Flash Player. With that said, let’s dive into the bulletins. 

MS17-001: Security Update for Microsoft Edge (3214288)

Kicking off the new year, surprisingly isn’t Internet Explorer, but Edge. This bulletin is important-rated and resolves an issue related to cross-domain policies, which can lead to privilege elevation. An attacker can potentially access information from one domain and inject it into another domain through the about:blank page.

MS17-002: Security Update for Microsoft Office (3214291)

Making its regular appearance, Office has only one vulnerability this month. Don’t think that means we’re letting Office get off easy, the vulnerability results in remote code execution and is rated important by Microsoft. The vulnerability stems from the usual object memory mismanagement. A successful exploit would execute code with privileges in context with the current user. Be sure your new year’s resolution involves exercising the principal of least privilege.

MS17-003: Security Update for Adobe Flash Player (3214628)

As usual, Adobe Flash Player is teeming with fixes this month. This bulletin has a Critical rating, since Remote Code Execution is possible. There are multiple vectors of attack from which an attacker can exploit a victim through these vulnerabilities. In a web-based attack scenario where the user is using Internet Explorer for the desktop, an attacker could host a specially crafted website that is designed to exploit any of these vulnerabilities through Internet Explorer and then convince a user to view the website, or leverage an already compromised website. There are mitigations that can be taken to blunt the damage an attacker could do to your system, the most effective being to disable Adobe Flash Player from running in IE or Edge.

MS17-004: Security Update for Local Security Authority Subsystem Service (3216771)

Probably the only unusual face on this patch Tuesday, the Local Security Authority Subsystem Service does have a denial of service vulnerability. An attacker could trigger LSASS by sending a specially crafted authentication request, which would result in a malfunction that would initiate an automatic reboot of the system. This vulnerability is rated as Important by Microsoft, since its impact is only denial of service.